Rockbox

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bugs
  • Category User Interface
  • Assigned To No-one
  • Operating System Gigabeat F/X
  • Severity Low
  • Priority Very Low
  • Reported Version Daily build (which?)
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Rockbox
Opened by EricJorgensen - 2009-01-15
Last edited by fg - 2010-01-22

FS#9803 - Conflict between Car Adapter Mode and First Buttonpress Enables Backlight Only

Build R19503_081220 on Gigabeat F.

With both “Car Adapter Mode” and “First Buttonpress Enables Backlight Only” enabled, if the gigabeat is booted on battery power and then DC power is applied, the “first buttonpress” functionality persists even though the backlight is always on - the first buttonpress after the (now cancelled) backlight timeout is just thrown away.

If i power up the gigabeat with DC already applied, it behaves normally.

Closed by  fg
2010-01-22 21:00
Reason for closing:  Fixed
Additional comments about closing:  

Reported as fixed

I should have said, the issue is with the “backlight (while plugged in)” feature. Which i confused with car adapter mode.

“backlight (while plugged in)” is set to “on” but if i power up the gigabeat w/o external power, use it for some time, then plug it in, i find that i lose the first buttonpress. If i plug it in, then power it up, i don’t lose button presses.

Having updated to a 3.1 build with a tweaked button map (seriously, play/pause on “A”? I understand why page scrolling had to move, but . . . . ) I can’t seem to replicate this anymore.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing