Rockbox

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bugs
  • Category Settings
  • Assigned To No-one
  • Operating System Sansa e200
  • Severity Low
  • Priority Very Low
  • Reported Version Version 3.1
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Rockbox
Opened by kingsinger - 2009-01-16
Last edited by bluebrother - 2011-06-05

FS#9807 - No header info in the .Scrobbler log

I’m using the newest build of RB on a Sansa e250. I just started using Last FM, so I turned on the scrobbler log. When I tried to upload with QTScrobbler, it said it couldn’t parse because of missing header info. When I examined the log file in the text editor, after looking at the Scrobbler log spec on the LastFm site, I saw that there was no header info in there.

When I inserted header info manually, Qt Scrobbler could then parse the log file and scrobble the tracks.

I don’t know if this is a new bug, or something that has been this way for a while.

Closed by  bluebrother
2011-06-05 11:20
Reason for closing:  Out of Date
Additional comments about closing:  

no activity since last request for confirmation, which is already a year ago.

what header is qtscrobbler expecting? and where is the actual spec for the log file?

obo commented on 2009-02-02 13:51

http://www.audioscrobbler.net/wiki/Portable_Player_Logging

If the log file doesn’t exist the header is added… is an empty log file being manually created?

I’ve seen the scrobbler log file sometimes not having a header, and corrupted first few lines. I wonder if file isn’t cleanly closed/flushed on exit in some case. If the file gets corrupted, then a header won’t get re-added, of course.

Does this still happen?
Can you reliably reproduce it?

Please report rockbox version as the exact number when submitting a bug, “newest build” is completely useless when looking at the bug some time later.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing