Rockbox

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bugs
  • Category Music playback
  • Assigned To No-one
  • Operating System All players
  • Severity Low
  • Priority Very Low
  • Reported Version Version 3.1
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Rockbox
Opened by rasher - 2009-01-22
Last edited by jdgordon - 2009-12-16

FS#9819 - Rapid skipping causes next track info to stop updating

The summary pretty much says it all: My usual listening pattern is to add most or all songs on my player, and skip songs I’m not in the mood for. This occasionally results in a lot of skipping (past say, 5-10 tracks), and while I do this the next track info will stay the same, so if I have a playlist of Track1-Track20, and am listening to Track1, and start skipping, the next track will continue to be Track2. I *think* that the next track info is only updated once I stop skipping and a complete rebuffering to the new location has been done, though this is just speculation.

I’m not 100% sure this happens everytime, but I see it often with my usage pattern.

Closed by  jdgordon
2009-12-16 08:56
Reason for closing:  Out of Date
Additional comments about closing:  

rasher, reopen if its still happening… no repro 6 months ago is long enough

this isnt really a bug that im is worth worrying about… the problem is the CPU/hdd just isnt fast enough to keep up. Untill the buffering is done there is no way to get the next tracks id3 info… when a track i buffered it happens in this order:
1) id3 info
2) AA if enabled
3) audio

this happens untill it runs out of room on the buffer, then the first track off the buffer has its id3 info loaded to make sure it can be displayed…. what you are doing though is trashing the buffered info too quickly so nothing is buffered at all, and you are still skipping so you keep trashing the buffer… nothing can be done about this.

As long as the next track info (or all track infos) is fine again once you stopped rapid skipping I wouldn’t call this a bug.

“Fixing this” would maybe mean to disallow fast skipping, and I wouldn’t want that.

I disagree. At the very least, as soon as the Next track info is no longer valid (after the first track skip) it shouldn’t be showed, I understand that there might not be any infor ready to display, but displaying a song I skipped past many tracks ago as the next track, for 10-15 seconds is just wrong.

i agree with rasher, the wrong information should be immediately deleted when its no longer valid. i think a empty “next song” is better then a wrong “next song”.

Is this still happening?

I can’t reproduce it.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing