Rockbox

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bugs
  • Category Rbutil
  • Assigned To No-one
  • Operating System iPod 5G
  • Severity Low
  • Priority Very Low
  • Reported Version Version 3.1
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Rockbox
Opened by ian - 2009-01-26
Last edited by bluebrother - 2009-11-22

FS#9833 - WinPod misdetected as MacPod in rbutilqt

Tried to install RockBox 3.1 on my iPod 5G with the OSX RButilQT utility v1.0.9. My iPod was incorrectly detected as a MacPod, despite both iTunes, fdisk and ipodpatcher (???) agreeing on it being a winpod with the partition table signature 0xAA55. I’ve attached the partition table (built from dd if=/dev/disk8 of=iller.bin bs=512 count=1).

Managed to install with ipodpatcher manually, but this bug made the first-time user experience very frustrating.

Closed by  bluebrother
2009-11-22 16:39
Reason for closing:  Fixed
Additional comments about closing:  

fixed with r23707. Note that waiting for the system to remount the player is still not missing, causing issues in automatic install (see  FS#10100 ).

Rockbox Utility uses *exactly* the same code as ipodpatcher, and relies on ipodpatcher for detection, thus also macpod detection. Please elaborate in detail what you did – especially your claim of “ipodpatcher (???)” is surprising – why (???)? Also, did you unplug and reattach the ipod after converting, and did you this before running Rockbox Utility or before running ipodpatcher?

Project Manager
zagor commented on 2009-01-27 07:30

Looks like this is a generic mac issue – this thread http://forums.rockbox.org/index.php?topic=20957 looks like the same issue.

The results posted in the forums here http://forums.rockbox.org/index.php?topic=20957.msg146737#msg146737 make me believe that this is a bug introduced with the bootloader rework that was done after 1.0.7.

Also encountered this bug, using OSX RButilQT 1.2.2. Autodetect was never successful, nor was RButilQT bootloader installation(error: “could not open ipod”). After reformatting to FAT32 using mkfs.vfat, manual bootloader installation was successful using ipodpatcher 3.0 with 3.0 bootloader, but encountered  FS#9568  when trying to boot rockbox.

Reformatting FAT32 using windows and itunes restore still did not allow autodetect, and still resulted in this bug, but manual installation was successful.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing