• Status Closed
  • Percent Complete
  • Task Type Bugs
  • Category Music playback
  • Assigned To No-one
  • Operating System Sansa e200
  • Severity Low
  • Priority Very Low
  • Reported Version Version 3.1
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Rockbox
Opened by sduck - 2009-01-29
Last edited by fg - 2009-12-17

FS#9849 - Playback stutters, crashes player on certain mp3 files

Sansa e280, daily build from 1/28/2009

On a very small number of my MP3 files, playback at the start of the song will stop and start a few times, usually 3 times, and occasionally crash the player. The playback will start normally, and after about 3 seconds will stop for about 5 seconds, and repeat this 3 times. These files weren’t ripped by me, but they appear to be normal Lame type rips, and play in other players fine. I tried attaching one of the files that does this, but it’s too big - download it here - - Time.mp3

Closed by  fg
2009-12-17 22:09
Reason for closing:  Fixed
Additional comments about closing:   Warning: Undefined array key "typography" in /home/rockbox/flyspray/plugins/dokuwiki/inc/parserutils.php on line 371 Warning: Undefined array key "camelcase" in /home/rockbox/flyspray/plugins/dokuwiki/inc/parserutils.php on line 407

Fixed according to the original submitter

That file has a huge ID3v2 tag at the beginning. Does removing that tag make it play properly?

sduck commented on 2009-01-30 02:55

No. There is an image in that header - I tried first just removing the image, and then completely removing the ID3v2 tag, but the behavior was as before - no change. I also tried this the last time I had this happen, back in December, with the same results.

sduck commented on 2009-01-30 17:41

I’ve uploaded a version of the same file without the embedded image if it will help - this version still does the stuttering thing.

i would like to note: I have been having somewhat the same issues for a while now, what type of crash are you seeing, is it a data abort, or does it just freeze and die? mines a data abort on my e250s always at the location of 000090D0 (0). this still happens occasionally with my media files… but like you, only a few, and i encode with lame

sduck commented on 2009-02-02 23:17

My behavior is as described above. On the odd times that it crashes, I don’t get an error message - the info on the wps just goes blank and the unit freezes. It’s probably some kind of encoder setting that doing this - it’s just certain groups of files, not ripped by me, that do this.

I have never been able to reproduce this on a 5G iPod. I don’t know why it would only happen on an e200 series Sansa.
If you get a data abort or any other kind of error message which gives the address please report the address and post .rockbox/rockbox.mi4 so it is possible to find what instruction is causing the problem. The address depends on the particular build because things can move around between builds.

sduck commented on 2009-04-22 16:16

I don’t know about ipods - there’s a quite a few differences in the hardware and software involved, so different results would be expected.

And as I’ve noted before, I don’t get an error message of any kind, just the behavior as noted.

I should mention that I haven’t tried this file recently on any newer builds - it’s sort of become a non-issue for me, and as I can’t get anyone else interested in taking a look at it, if someone wants to close this, that’s fine with me.

sduck commented on 2009-10-19 03:28

Just tried this on a recent build - no problems on playback - issue resolved as far as I’m concerned.


Available keyboard shortcuts


Task Details

Task Editing