Rockbox

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bugs
  • Category Settings
  • Assigned To No-one
  • Operating System Iriver H100 series
  • Severity Low
  • Priority Very Low
  • Reported Version Version 3.1
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Rockbox
Opened by klawit - 2009-01-30
Last edited by Buschel - 2011-10-21

FS#9851 - settings not saved when disk is not spinning

Rockbox seems not to save settings when there is no disk spinup between changing and shutting down. I realized this is true for Rockbox 3.1 since current build r19559.

Closed by  Buschel
2011-10-21 12:30
Reason for closing:  Works For Me
Additional comments about closing:  

Works for me.

how are you shutting down? it *should* force a write if something changes…

Well, I push the stop button for a couple of seconds. Then a message “shutting down” (I use german language settings, text might be different) appears and the unit goes off some seconds later but the red HD light will not illuminate.

petur commented on 2009-02-01 14:36

strange, rockbox flush save any pending writes at the next spinup or shutdown… so you do not hear the disk spinup at all? Which settings did you change?

also *how* did you change the setting?

I have the same problem with my Iriver H340 using rockbox 3.1 and build 19868.
When I shut it down and start it again, the playlist position is often (always ?) lost.
It didn’t occur in rockbox 3.0 (if I remember correctly)

I didn’t change much. In fact I deleted .rockbox and reinstalled to be shure there is no prob with an old config.
There is no spinning. Maybe there is a problem how CF cards are implemented as they don’t like to be suspended (set asleep). I didn’t change anything except

- database was initialized
- load database to RAM
- directory cache set to on

Shutting down takes quite much time (up to 6-8 sec.) even if nothing is flushed to disk.

I think settings *are* saved. The problem is that the playback position is not saved and/or resumed properly.

Actually, playback position saving and resuming works. I remember resuming to 0:00 several times recently, but that was because I was playing ALAC and resume doesn’t seem to be supported on that format. Another file I tried is a FLAC which starts with some silence, and the bitrate of that part is so low that Rockbox thinks an offset there is less than PCM latency.

is this still a bug ?

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing