Rockbox

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bugs
  • Category User Interface → Themes
  • Assigned To No-one
  • Operating System All players
  • Severity Low
  • Priority Very Low
  • Reported Version Version 3.1
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Rockbox
Opened by Alexander Levin - 2009-02-11
Last edited by Thomas Martitz - 2009-02-16

FS#9894 - Position of the progress bar is not updated after the font is changed

The problem occurs with r19974, at least in the simulators for e200 and h120.

I use the following WPS code which can be used with many fonts:

%we

%ac%s%?ia<%ia|%d2>
%ac%s%?it<%it|%fn>

%al%pc%ac%pp/%pe%ar-%pr
%pb

%ac%s%?It<%It|%Fn>

Now, how to reproduce:
1. Start playing a file
2. Go to the main menu, theme settings, and select another font (different height) (the file is still playing)
3. Leave the menu, go back to the WPS

The WPS is drawn using the new font, but the progress bar is shown at the old Y-coordinate. “Playing” the WPS file (which is in use) again brings it to the right position again.

Closed by  Thomas Martitz
2009-02-16 08:37
Reason for closing:  Fixed
Additional comments about closing:  

Fixed in r20015.

Alexander Levin commented on 2009-02-12 21:38

The problem seems to be that the Y-coordinate of the progress bar is fixed during the parsing of the WPS – even if the %pb tag doesn’t contain any parameters. In such case the Y-coordinate should be computed not during the parsing but during the actual rendering IMO. Then the current font size would be taken into account.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing