Rockbox

  • Status Closed
  • Percent Complete
    100%
  • Task Type Patches
  • Category Plugins
  • Assigned To No-one
  • Operating System All players
  • Severity Low
  • Priority Very Low
  • Reported Version Daily build (which?)
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Rockbox
Opened by mud - 2009-02-13
Last edited by DrMoos - 2009-02-21

FS#9901 - Goban overlay for Archos targets

This is an attempt to turn the goban plugin into an overlay for the recorder and ondio targets (where the plugin buffer is too small for it to run normally).

goban-overlay.patch is the actual patch.
To run it in test mode apply turn-on-testing.patch IN ADDITION to the other patch, and unzip test_sgfs.zip to your player root.

You have to watch the screen a little bit for the test suite, as the result is only reported there (it will clearly say if it passed or failed).

Closed by  DrMoos
2009-02-21 00:36
Reason for closing:  Accepted
Additional comments about closing:  

Commited as r20069. Merci!

mud commented on 2009-02-13 12:17

pixelma was kind enough to test this for me on Archos Ondio. It sounds like it worked except that the automated test failed (line 823 in util.c, testing a comment for changes after saving and loading).

log:
http://www.rockbox.org/irc/log-20090213#12:00

I am unsure of the cause of that failure, but I suspect that it’s probably not related to the overlay (I would have expected much more serious errors if it were that). I’ve had that test fail before on other targets, but not recently. It may be a lingering bug in general. I will investigate if I can.

Also, I forgot to mention. If you run the automated test, only the last message is very important. (lots of stuff will flash on the screen and messages being displayed). Just look for a message saying that all tests passed, or one saying what line failed. They will be shown for several seconds before the plugin exits.

There is probably also a bug in the goban.make file as pixelma reported that changes to goban.h did not result in the plugin being rebuilt.

mud commented on 2009-02-20 16:58

I have not been able to reproduce the makefile bug.

Here is a new testing patch, designed to give me more information if the same test fails as did for pixelma. It should be applied against svn directly, the turn-on-testing.patch is not necessary. It includes no functional difference from the original patch except more verbose testing is done (and testing is turned on by default).

Patched against r20063.

Note: you still need the test_sgfs.zip with this patch. Extract the .zip to the root of your player, apply this patch directly on svn, and run the goban plugin and it will run the tests. Please copy down and report here any numbers that it gives you, and report them here.

Also, please be specific about which version of the patch you’re reporting on as the line numbers will be different between them.

mud commented on 2009-02-20 20:35

Okay, the overlay has been tested by pixelma again (on ondio) and by LambdaCalculus37 (on recorder v1). Thanks to both of them. It passed both tests, so I’m pretty happy with this patch.

I build tested it on all targets and it seemed to pass that as well.

I also cannot reproduce the make bug still, so I’m hoping that it was just a fluke somehow. Here is a new version of the patch, which will hopefully be the final version. It’s basically the same as the first version, just with some unreleated changes taken out.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing