Rockbox

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bugs
  • Category Playlists
  • Assigned To No-one
  • Operating System iPod Nano
  • Severity Low
  • Priority Very Low
  • Reported Version Daily build (which?)
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Rockbox
Opened by RadioactiveMan - 2009-02-16
Last edited by stripwax - 2009-07-12

FS#9913 - Moving items in a shuffeled playlists highlights the wrong entry

Using Version 20016-090216

Hello,
Moving items in a shuffeled playlist doesn’t work as expected.

Here are the steps to reproduce.

1. I create a playlist by selecting the first file in a directory
2. I enter the Quick screen
3. I set shuffle to yes end leave the quickscreen
4. I go into the context menu and let rockbox show the current playlist
5. Now the songs are in the following order:
01, 08, 02, 03, 09, 10, 11, 07, 04, 12, 06, 05

6. Now I want to move song 07 right after 02.
7. I select 07 and select ‘move’ in the context menu
8. Instead of highlighting and moving the song 07 rockbox takes the song 11.
9. Moving the highlighted entry after song 02 the playlist looks as follows:
01, 08, 02, 07, 03, 09, …

This wrong highlighting happens with every song. In this particular case it is always the song before the selected one that gets highlighted.

In different playlists it is not always the song before the meant one. For example on one album with 15 song (101, 106, 115, 110, 113, 104, 107, 102, 105, 108, 114, 112, 103, 109) selecting 107 highlights 103, 102 highlights 109, 105 highlights 101.

Closed by  stripwax
2009-07-12 12:19
Reason for closing:  Duplicate
Additional comments about closing:  

Duplicate of  FS#7967  (which has now had a fix committed)

This is a duplicate of  FS#7967 

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing