Rockbox

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bugs
  • Category Battery/Charging
  • Assigned To No-one
  • Operating System Sansa e200
  • Severity Low
  • Priority Very Low
  • Reported Version Version 3.1
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Rockbox
Opened by Trevor Green - 2009-02-16
Last edited by Thomas Martitz - 2009-03-08

FS#9914 - Sansa e280 locks up when plugging in USB

Plug in USB cable when Rockbox is running and the battery icon changes to show charging. Immediately a new screen appears showing a USB plug icon then the screen fades aweay and the player hangs.

I raised an issue previously #9801 which was closed as a duplicate of #9236. #9236 has been closed as fixed in r19819 but this issue still exists as of r19933.

Have searched for issues using "USB" and "Charging" but could find nothing.

Just tried with r20016 and now screen corrupts before displaying USB plug icon (on hte WPS screen).

Hard reset required to get rockbox working again.

Appologies in advance if I should have re-opened either #9801or #9236.

Closed by  Thomas Martitz
2009-03-08 19:31
Reason for closing:  Fixed
Additional comments about closing:  

Seems to be fixed according to Trevor.

Trevor Green commented on 2009-02-16 11:47

Have just tested again with release r20016 and sometimes corrupts on WPS screen and sometimes on USB plug icon screen.

Johannes Linke commented on 2009-02-16 18:01

cant reproduce it. when rockbox runs and i connect the player to a computer, the sreen "fades away", then the scrollwheel turns on, screen becomes white and it boots as normal into the OF.

Trevor Green commented on 2009-02-17 08:47

The web site always used to indicate (prior to around 3.1 release) that battery charging was not supported, it now indicates that it is. Prior to the website changing plugging in the USB cable caused a reboot into original firmware, and if that is what still happens why has the website changed from unsupported to supported.
My iriver H100, when plugging in a charger or usb cable, will continue playing in rockbox and charge the battery. I would not call rebooting into OF as supporting charging. I am not trying to be argumentative here but surely either the website is wrong and charging is not supported or there is a bug causing charging not to work.

Johannes Linke commented on 2009-02-19 12:07

you got something wrong: charging *is* supported for e200 since r19748.

before this commit happened the following: if you connected the e200 to a computer, it reboots into the OF. if you connected it to a charger, it didnt do anything (it also didnt charge)
now the same happens, but with charging when connecting the player to a charger. it doesnt reboot into the OF then.

i dont know which revision you use, but it doesnt seem its a newer one.

Paul Louden commented on 2009-02-19 12:24

Charging is supported, that doesn't mean "charger detection" is guaranteed as depending on the charger, it may be identified as a USB connection. You simply need to force charging by holding down the Select button while plugging in the cable. You can also use this to force charging while connecting to a PC.

And H100s do not have USB charging.

Trevor Green commented on 2009-02-19 15:54

Paul the forcing charging by holding select was the bit i was missing, thank you that works (ps a typo I meant H10).

However contrary to Johannes comment when I plug the USB cable into the e280 not holding down the select button (r200016) the device definitely hangs (music stops and screen fades ring lights up but then just sits there) and I have to force a reset to bring it back to life. I would have thought the system should either reboot into OF or ignore the fact that the cable has been plugged in, not sure which is the 'right' solution but hanging definitely seems wrong. Should issue be used to report this or should I raise another issue and let this one be closed?

Must caveat all the above with the fact that I think Rockbox is excellent and bought the e280 knowing that the only bit missing at the time (charging) would be sorted. Just want to help make it even better!

Trevor Green commented on 2009-03-03 14:52

I have now installed r20192 and upgraded the bootloader to V5.0 and now all works. It was probably the bootloader that did it, I hadn't realised earlier that there was an upgrade to this.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing