• Status New
  • Percent Complete
  • Task Type Bugs
  • Category Remote
  • Assigned To No-one
  • Operating System PortalPlayer-based
  • Severity Low
  • Priority Very Low
  • Reported Version Daily build (which?)
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Rockbox
Opened by saratoga - 2009-02-24
Last edited by rasher - 2009-02-25

FS#9951 - Ipod Accessory bug reports

If your Ipod accessory doesn’t work with rockbox, you can report it here.

Please put your device name, Ipod model, and tested rockbox version in your post. If some but not all features work, be sure to mention that in your post.

Edit by rasher:
You should also add your results to this page page:

For any developers who might work on IAP support, please add patches to this task, so potential testers are notified.

iPod Video, 5.5G, 30GB model. The Kensington FM Transmitter w/RDS model K33364US: The iPod can charge from the unit, but the audio is not transmitted to the car radio.
Otherwise, appears to function normally.

I suspect this may not be easy to remedy, if at all. The transmitter has software code built in to it, which allows it to display the FM station (it’s transmitting on) on the iPod screen.

Contact me for help with testing.

Forgot. Rockbox v3.1

Dave: Please re-test with a current build - 3.1 doesn’t have any support for the Ipod Accessory Protocol.

I tried hooking up an 80GB iPod Video to my AVIC-D3 car stereo. It could sucessfully charge, however playing audio didn’t work. The stereo was also unable to get playlists or search by artist/genre.
I tried with r20074-090221. It should have been a daily last weekend or so.

   Tested my Kensington transmitter with current 20102-090225. The iPod charges, and the audio does get transmitted. But the track title and track artist still doesn't get transmitted to the radio display, via the RDS protocol. Can this be implemented?
   When I look in System - Debug - View I/O ports, the ACCESSORY number alternates, mainly on 867, then frequently to 866, and occasionally to 869, 864, 863, and once or twice I saw 865.

Status update with my stereo:
I changed the stereo to Video mode. This is for watching videos from the iPod where the stereo pretty much just acts like a TV. It displays whatever is on TV out and plays any audio coming out of the iPod port. When doing this, I can hear the music from the iPod. However, remote doesn’t work (and it never was designed to) requiring control directly from the iPod. Music mode does not work at all. There it allows you to search by Album, Genre, Artist, etc. and control the iPod. In this mode nothing happens.

Forgot to mention, this was r20112-090226

Tested on two remote control devices using both an iPod Video 5.5G 80GB and a Nano. Each remote works OK, but not completely, with slight differences between the two different iPods. Codes read from the 5.5G as the Nano screen is too small to view full hex code.

Rockbox version r20200-090304. I’m not a programmer so can’t contribute to the code, but if there is any other info I can provide to help this project, let me know.

1. Logitech PureFi Anywhere 2,en
These rechargeable portable speakers include a remote control. Volume on remote operates the speaker volume, not the ipod, so N/A here.
FF/RW and skip forward/back work, shuffle and random buttons work.
Play/Pause short press works, but reasonably long press activates menu mode, subsequent presses of play drill down in menus. Can’t back out of menus from remote because Menu, Up, Down, and Select do not work. Works with accessory power on, doesn’t work with accessory power off. In debug, Accessory: alternates between 0 and 1.
IAP packets: (?) indicates lack of confidence, some of these flashed so quickly, I can’t be sure I read the changing characters correctly.
base state: 03 02 0D F1 00 00 1D 00
Logitech power on: flashes 05 02 00 00 00 02 F7 00 (?) then 03 02 00 00 FB 02 F7 00 ,
powering off again: flashes 05 02 00 00 00 02 F7 00 (?) then 03 02 00 00 FB 04 F5 00
Play/Pause: quick press: FF FF 00 01 FA F9 F7 F6 (?) press and hold: 03 02 00 01 FA F9 F7 F6
RW: 03 02 00 10 EB 02 F7 F6
FF: 03 02 00 00 F3 02 F7 00
Menu: flashes 05 02 00 00 0B 40 B9 00 (?) then stays 03 02 00 00 FB 40 B9 00
Select: flashes 05 02 00 00 0B 80 79 00 (?) then stays 03 02 00 00 FB 80 79 00
Up: 06 02 00 00 00 00 01 F7
Down: 06 02 00 00 00 00 02 F6
Shuffle: 04 02 00 00 80 7A F7 F6
Repeat: 05 02 00 00 00 01 F8 00

2. Monster iEZClick RF remote. This is a weather resistant RF remote for operating an iPod tucked away in a pocket, say while skiing or snowboarding.
Volume up/down works, FF/RW and skip forward/back work as expected.
Play/Pause short press works but an unreasonably short press and hold on the remote, which is designed originally to turn on/off the standard ipod firmware (this would really be sleep/unsleep?), I get two different results in Rockbox on the Nano vs. the 5.5G. On the Nano this pauses, then activates menu mode, further presses on Play/Pause drill down in the menu. No way to back out from or return to now playing from the remote. On the 5.5G the Play/Pause press and hold works like pressing the center select button on the iPod during playback: takes you to the location of the currently playing track in the file tree. Allso no way to back ou from the remote. On the remote pressing play/pause and FF or RW simultaneously is originally designed to go to next or previous playlist. Not sure how Rockbox might use the last two, currently seems to have no effect in Rockbox. Switching between playlists might be cool. I can imagine one playlist for on the ski lift and another for the run.

Importantly for this particular device, the delay allowed between a quick press and a press and hold is very small. It is too easy to accidently send the iPod into menu mode by pressing the play button for more than the shortest tap. Since menus are not useful for this device, perhaps this play and hold could be deactivated for this device in Rockbox?
ACCESSORY: 0, 1, 2, and 3 seen, mostly 0 and 1.
IAP packets again read from 5.5G:

base state: FF FF FF 00 00 00 00 00
Play/Pause: quick press: 03 02 00 00 FB FF FF FF press and hold: 03 02 00 01 FA FF FF FF
RW: 03 02 00 10 EB FF FF FF
FF: 03 02 00 08 F3 FF FF FF
Volume up: 03 02 00 02 F9 BA FF FF
Volume down: 03 02 00 04 F7 BA FF FF
Play/Pause + FF 04 02 00 00 20 DA FF FF
Play/Pause + RW 04 02 00 00 40 BA FF FF

Hope this is helpful.
Very happy that iPod Accessory support is advancing. One of the advantages of using these particular devices is the wide range of accessories available for them.
Many thanks to all you coders!

My headunit is sending a mode 4 “0×00 0×28” command. Meaning, according to the description of the AAP protocol, to execute playlist selected earlier in 0×00 0×17 command at the track position in parameter. The current code does not handle this command. Do you think it should actually be a “start playing current selected playlist” command ? I’m not sure I understand the “execute” playlist.

I added a log function to IAP. It’s logging ingoing and outgoing IAP packets in “seriallog.txt” file, in the root folder. You can find it in the attached patch file (diff with 3.2 sources). I hope it can help finding problems. Header (FF 55) and checksum are removed from the log. Should look like this (example taken from the connection to my Alpine headunit, only the first few packets sent) :

–> 03 04 00 12
←- 05 04 00 13 01 0B
–> 03 04 00 33
←- 08 04 00 34 01 36 00 A8 01
–> 12 04 00 32 00 00 01 00 01 00 01 00 00 00 04 00 00 00 00
←- 06 04 00 01 00 00 32
–> 03 04 00 1C
←- 0C 04 00 1D 00 00 00 00 00 00 00 00 00

kiese commented on 2009-05-30 19:09


I have such a Dockingstation:

But my iPod don’t react or very bad by pushing buttons on ir-remote.

It works fine by runnin in Apple-Software.

What can i do, so it works?


iPod Mini 1G, three accessories in use here. I also have access to a couple of Nanos (currently not running Rockbox - they belong to other family members) that I might be able to do some testing with.

1st, iHome with IR remote. Playback works, as does charging. Remote doesn’t do anything significant to the iPod (the play button causes a momentary pause/resume, and the remote turns the volume up/down but that’s handled in the iHome and not the iPod). Track switching and iPod menus non-functional.

2nd, Belkin auto kit. If I boot into the Apple firmware and plug the device into the Belkin RF transmitter, it’ll tune the station; I can then reboot and use Rockbox as long as I don’t lose power (ie, accidentally unplug the Belkin from the lighter socket in the car) and leave the iPod plugged in. Can’t retune to another frequency without a reboot - buttons on the device are completely non-functional.

3rd, JBL “On Time” docking station. I don’t use this a lot myself, but I can test with it if that is of use.

Sorry, should add that I’ve tested with several daily builds, tested with 21183 most recently, just updated to 21476 this afternoon. I am set up to patch and build if needed.

Veloz commented on 2009-07-18 22:50

60GB iPod Photo (r21884-090715) with Ten naviPlay (NIA-S10-M) BT adapter and Motorola S9-HD headphones

Audio works great, no FF/RW or Play/Pause controls.

Full control of my iPod 5.5G was working with two simple accessories previously with the former IAP build before it was commited to SVN, it still works :)

*Altec Lansing IM600 docking station (
-Play/Pause works as expected.
-Prev/Next skip (short press) works as expected.
-Forward/Rewind (long press) works as expected.
-Long press on Play/Pause switches between “Now plating” and previous menu called (menu control is impossible with only two buttons).
-Charging works too.
-Volume control is totally indepedent: it goes from 0 to 30 on the dock. It doesn’t have any effect on Rockbox (even visual). Rockbox volume control has no effect on output volume too.
*Griffin AutoPilot (
-Play/Pause works as expected.
-Prev/Next skip (short press) works as expected.
-Forward/Rewind (long press) works as expected.
-Long press on Play/Pause switches between “Now plating” and previous menu called (menu control is impossible with only two buttons).
-Charging works too: a 2-LED combination tells you about battery charging status.
-Track info through RDS was partially working, sometimes late or stuck on previous track (I need to restest it)

Tested with unsuppoted IAP build until latest Rockbox build, with “Accessory power supply” both on and off (no effect on compatibility) and “Serial bitrate” set to “Auto”.
I don’t know how to add those results on the TWiki :)

Currently I can’t manage to establish communication between my 5.5G iPod and my Kenwood car headunit (a KDC-W6541U wih built-in iPod control) under Rockbox.
It works fine with Apple firmware, the Kenwood logo shows up on screen and everything is under control through the headunit.

***Kenwood KDC-6541U headunit (
-Until 3.2 release: All different options and combinations tested (i.e. Accessory Power Supply, Car Adapter mode…) but once it’s plugged to the headunit, Rockbox goes into disk mode, then the headunit displays “iPod error”, then disk mode says “OK to disconnect”.
I tried to turn “iPod mode” off into the headunit options → same result.
I can’t go any further… The headunit is stuck with its “iPod error”.

-After 3.2 release with new USB mode, behaviour is the same except Rockbox doesn’t reboot into disk mode, but USB mode.

Pressing “Menu” while inserting the cable to prevent Rockbox from going into disk mode/USB mode unfortunately doesn’t help → same “iPod error” on the headunit.

Too bad because this headunit won’t even recognize the iPod as a standard USB storage device (”iPod mode” off)… Any help appreciated to help this work!

Alex :(

Some additionnal info for the Kenwood KDC-W6541U headunit:
Values taken from the “View I/O ports” screen.

-Normal status, Kenwood headunit off/unplugged:

A: 28 E: 21 I: 58
B: F9 F:02 J: E3
C: F0 G: 00 K:1E
D: A0 H:00 L: A8

GPO32_VAL: 40004000
DEV_EN: C0011966
DEV_EN2: 00000000
DEV_EN3: 0000003F
DEV_INIT1: 00040000
DEV_INIT2: 40000000
IAP PACKET: 00 00 00 00 00 00 00 00

-Kenwood headunit plugged:

A: 28 E: 20 I: 58
B: F8 F: 02 J: E3
C: F0 G: 00 K: 1E
D: A0 H: 00 L: B8

GPO32_VAL: 40004000
DEV_EN: C041196E
DEV_EN2: 00000000
DEV_EN3: 0000003F
DEV_INIT1: 00040000
DEV_INIT2: C0000000
IAP PACKET: 00 00 00 00 00 00 00 00

Disconnecting the headunit, return to “normal” values.

Test was made inside the debug menu, or with “Menu” key pressed while plugging in order to access the debug. Both and also all options show same result (”Accessory power supply”, “Serial bitrate”, etc…).

Pressing keys on the headunit don’t send IAP packets (always 00 00 00 00 00 00 00 00). The headunit says always “iPod error”.

Hope this helps!

Update: after having using latest build (22166) patched with Cédric Maire’s IAP logging, the test shows that IAP communications between Rockboxed iPod and the headunit are completely silent…

On my iPod Video 30gb, when connected to a Monster iCarPlay200 Wireless 200, on the 3.3 release. The iPod will randomly pause itself, turn on shuffling (no matter what the actual setting is), unpause itself, play for a few seconds, turn off shuffing, pause itself, then play again. It will continue this as long as it is plugged into the iCarPlay. The iCarPlay did work on a previous build of rockbox (one of the rXXXX versions).

slightly better logging, only in works though (or at least for me….)
logs to a buffer and flushes to disk when the disk is spinning already…. I might just make this a setting and get it commited soonish

You may test a fresh build with FS 10494 (ipod remote patch): it features a better accessory identification and should help to detect the accessories like docks,etc.

Donpipo: about your Kenwood KDC-6541U, it looks that it is connected with USB, and iap over usb isn’t coded yet.

I have a mini2g and the wired remote don’t work. Does any patch out there make the remote work? I’m new to rockbox and i’m still trying to patch :S.

Serial is not enabled on mini2G, so there’s no chance to make it work right now.

Is this remote connected to the dock port or is it something like an extra ring on the headphone plug?

Oh, I see :( You can see the remote in this page (generation 3):

Mini2G has the same hardware as the Color, that is supported.

So, it is possible to activate it on Mini2G, the only thing is I really don’t know if the UART activated would be connected to that port.

Is what you call “IAP over USB” what Kenwood (and other headunit manufacturers) “iPod 1-Wire Connectivity”? Some info here: Just out of curiosity… Thanks for clues!

Yes, it is.

That “one wire” features the accessory protocol over usb plus digital usb audio (”Simple connections plus enhanced audio quality” as they say)

HariD commented on 2010-02-22 05:19

I have an ipod mini 2nd gen that works well with the the maxell ipod remote control (this one:|B0007XFGC2&CPNG=&ref=tgt_adv_XSG10001), but rockbox doesn’t recognize it. I have the rockbox version r24803-100221 installed. Is there anything I can do to see if rockbox is recognizing the accessory? What are these hex codes that folks are referring to?

As said before, rockbox doesn’t recognize any accessory on ipod mini 2n gen since serial is not enabled on it…

If you have any C skills, you could try to enable serial on it to find out what’s happening

AndyP commented on 2010-02-24 21:23

I have a 5.5G iPod 80GB and have just tried connecting to a Hitachi AX-M136i Micro HiFi using build r24889M-100224.
The following keys on the Hitachi remote appear to work OK,.
Pause/Play, Random, Next Track, Previous Track, Volume +/-.

The FF and Rewind keys sometimes appear to function as FF (+ 5 seconds) and Rewind (-5 seconds) but at other times they act as Next Track and Previous Track.

The following keys do not work in the same manner as the Apple software.
Album + (Next Album), Album - (Previous Album), Stop, Power Off.

I will try again with the FS10623 IAP Remote V4.0 patch when I get some time and see if there is anything different to report.

Is there anything else I can try and report back on ?

AndyP commented on 2010-02-27 21:21

Tried again with r24889M-100224 with FS10623 patch on my 5.5G 80GB with the Hitachi AX-M136i and found the following.

Accessory Value 869/870

Remote Key Action Code
Power On - Plays ‘Resume Playback’ Code 06020000 0002
Pause/Play - Pauses Code 06020000 0200

  1. Plays Code 06020000 0100

Stop - No Effect Code 06020080 0000
»| - Next Track Code 06020000 0000
» - Next Track if short Press Code 06020000 1000

  1. Fast Forwards if long press

|« - Start Of Track if short press Code 06020000 0000

  1. Previous Track if long press

« - Rewind seconds if long press Code 06020000 0020
Random - Random next track Code 06020000 8000
Alb + - Nothing Code 06020020 0000
Alb - - Nothing Code 06020040 0000
Standby - Displays Charging Code 06020000 0004

mg0rb commented on 2010-02-28 04:39

How can serial be activated on mini 2nd gen ?

iPod 5G 32MB build of anything after Rockbox 3.4 (so 3.5 and 3.6 do not work) with <a href=”“>Sony Bluetooth adapter for iPod</a>. No joy. Tried stable 3.6, and current build (r27850 at time of writing)

Normal operation in 3.4 is: Turn on, plug in, iPod is discoverable. Would love the newer features and stability of 3.6, but this is definitely stopping me from upgrading this particular iPod

Also, iPod 4G Grayscale screen has same issue, only in 3.4

Iaplogging updated on rev.27860

Testing the Macally iVoiceIII Microphone with an iPod Video 60g, rockbox version r27773-100811.

This is a mono microphone which plugs into the dock port and also provides a stereo line-in port:

In the iPod firmware, it is detected automatically: the iPod switches to Voice Memo. When recording, a blue LED lights up inside in the microphone. Nothing happens when connected to Rockbox, although the following accessory and IAP packet values appear on the debug screen:

Accessory values: 0, 1 and 2.
IAP Packet: 0E 00 13 00 00 00 03 00

The line-in feature is working with Rockbox’s recording screen, but the microphone isn’t.

Do you have a dev environnement set up?
Could you try to patch iap_logging_v1.1.patch on latest svn and post the log?
It would help me a lot

Yep. Here is a log of inserting and removing the iVoiceIII. The contents repeat exactly if you insert and remove it again.

Inserting a jack into the bottom of the microphone (the only other thing you can do with it) does not affect in the log.

Using an iPod Video 30GB, Rockbox 3.6, SVN r28099, patched with the v1.1 Patch. Accessory is the Sony Bluetooth dongle. Nothing happens at all when plugged in, but the IAP section in the I/O ports moves around a bit in the 90s.

Using an iPod Video 30GB, Rockbox 3.4, SVN r24500, patched with the v1.1 Patch. Accessory is the Sony Bluetooth dongle. Nothing happens at all when plugged in, but the IAP section in the I/O ports moves around a bit in the 90s.

Attached patch cleans up apps/iap.c a bit.

* separated the functionality for the various modes into their own static functions (one function per mode), making the code more manageable
* added a single function to send a mode 4 OK response and avoid code duplication.

This patch actually makes the binary about 500 bytes smaller, source size is about the same :)

Please try, I can’t test this myself because I don’t have and ipod + accessory.

   iap.patch (43.3 KiB)

Using an iPod Video 30GB, Rockbox 3.7.1 iHome iP90. Audio out only works when I the play/pause button first then put it in; the audio only comes out at half the volume it should be at. None of the buttons work or interact with the iPod when its in the rockbox firmware. Charging is also intermittent.

AndyP commented on 2010-12-15 21:02


I am trying to use my iPod 5.5G 80GB with an Alpine CDE-103BT Head Unit.fitted with a KCE-433iV cable. The unit works perfectly with the Apple Firmware but with Rockbox build 28831 the Head Unit only ever displays SEARCHING or ERROR-01. I have done a bit of digging with the iaplogging patch as well as using a breakout cable to capture the commands used by the Apple firmware and it appears that the Head Unit sends an Apple Computer Certificate Authority file to the iPod using Mode 0 command 15 and expects and a response back from the iPod using Mode 0 command 17 which I assume contains an encrypted response. Without the correct response, the Head Unit keeps sending a reset and then requesting the correct response again. Is there anyone out there who can assist me in trying to get this Head Unit to work with Rockbox ? I have a development environment using VMWare and willing to try anything to get this to work. I did notice that Ryan Press (rpress) managed to dissemble the Apple firmware. ( FS#8624 ) and I wonder if the dissembled output from the firmware would help in the IAP commands used by Apple.



ebbi commented on 2010-12-16 16:58


I really like Rockbox and I use it for over one year now.
Have got an “iPod radio remote” cable for my iPod Video 30GB which you can plug into the dock connector.
When I start to hear radio it works just fine, but after ~ 10 seconds or so I hear a clicking sound in the right channel, than it fades to the left like you would turn a balance control to the left and from then on I only hear on the left side of my headphones (regardless of whether plugging the phones directly into the iPod or into the radio remote). Also the volume from radio remote and from iPods click wheel is not synchronous and the buttons of the remote control act with latency.

I switched to the apple firmware while booting…radio works in stereo and volume is synchronous all the time, all buttons work instantly (”iPod radio remote” requires iPod Software v1.1 or newer, I have v1.3).

Seems 2be some latency bug in the radio plugin from rockbox?!

Hope this report helps a bit making rockbox even better.
Thanks for this great jukebox system!!!

btw: Is there a functioning remote that have the exact buttons from the ipod with menu button on top and pause button at bottom instead of volume control like the radio remote has so you can use/make a kind of gamepad for playing with “zxbox”?


in iap.c→mode0→case 15, could you remove the lines “iap_send_pkt(data0, sizeof(data0))” and “iap_send_pkt(data1, sizeof(data1));” and recheck if it passes the authentication challenge?

On the ipod fm radio, if you answer to a command 15 with a command 19 instead of 16+17, it acknowledges the authentication process without even dealing with the certificate commands( 17 and 18)

It’s exactly what case 15 is doing, but maybe the commands order confuses your head unit.

If it does not work, you can try to send a command 16 before the 19.

AndyP commented on 2010-12-18 21:29

Hi Creposucre,
Thanks for the suggestion. Removed the two lines but still doesn’t pass authentication.
I have attached the log file that was generated with these changes (seriallog.033.28837) as well as the log file from the Apple OS (
I did change iap.c→mode0→case 05 by removing the last data[] byte (0×28) so as to reply the same data as the Apple firmware to the Alpine.
I’m willing to try anything to get this to work.

the ipod answer is a bit strange… with the fm remote, it sends only one time command 15…

You should try to acknowledge command 15 (00020015) and at the 8th sent, send the command 19.

if it doesn’t work, send command 16 and 27 to mimic the ipod firmware dialog, then try to send command19.

AndyP commented on 2010-12-23 19:32

When sending command 19 on the 8th sent, the comms stalls after the command 19 is sent. See attached seriallog.037.201012219130-19.
When sending command 19 after 16 and 27 on the 8th sent, the comms stall after replying to a mode 0 command 28. See attached seriallog.038.201012230650-19. This is futher than before but different to what the Apple firmware does.
Does anyone know what a mode 0 command 28 should respond with?

I think it’s because you answer with command 15 on the 8th sent, instead of replacing it by command 16.

One thing that is interesting is that it looks like it’s lways the same challenge; so the key that the ipod send back should be always the same.

so, replace command 15 by command 16 on the 8th sent, then send:

the accessory should send:
IN FF5503000F00EE
so send 0010000106

the accessory send
IN FF55020024DA
and send 00250000000000000001

AndyP commented on 2010-12-24 23:08

Done the above, now gets a bit further before stopping.
It now appears to be the same responses as the Apple firmware until it stops after the Mode 04 code 34 response to a code 33.
Any thoughts as to why it stops here ?

I have noticed that the Apple firmware doesn’t always send the same challenge., but it does appear to always send the same challenge when first powered up.


Could you try to send command 19 instead of 16?

And another test:

remove the send of command 14 at the beginning, and try to send a mode 4 command, e.g 03040012
The mode 4 commands request the authentication, but if the ipod doesn’t ask for it, you may be able to access them freely.

Device: Logic3 i-Station TimeCube
Status: partially working
What does work: ipod charging, pressing the “power” button on the clock sends “play” to the ipod, if set to “continue playback” the ipod will continue playback and the TimeCube will output the sound just fine.
What does not work: using the alarm function. When the alarm sets off, you can see on the clock that it starts in ipod mode, then shortly after (1 second) it’ll fallback to “annoying buzz” mode. Works fine in OFW 1.3

my uneducated guess: Either the clock can not identify the ipod properly or it hits some sort of timeout.

Ipod: 5.5G 80Gb (64Mb)
Rockbox: r28935

AndyP commented on 2011-01-02 22:27

Thanks for all the help so far,

Tried sending command 19 instead of command 16. See attached seriallog.192717. Comms stopped after sending the command 17 response.
Tried sending 04001D (Time/Status info) instead of command 14. See attached seriallog.04001D. Comms stopped after sending the 04001D.

Cars now in the shop being fixed. Will try sending 040012 to the Alpine when I get it back. Will report back the result.


AndyP commented on 2011-01-10 19:56

Car back from shop and have tried sending 040012 instead of 04001D. Gets a bit further, responses are

IN 0E0013000000110000000600000200
OUT 0400020013
OUT 03040012
IN 0304001C
OUT 0C04001D00048546000154BE01
IN 0404002901
OUT 06040001000029

Now appears to stop after sending a cmd OK in mode 4.

Any thoughts ?



hi -

long-time RB user, first time car-with-ipod-connection owner. i’d love to be able to help at the level of detail of andyp but not sure how.

here’s my situation:

iPod: 5G Video (80GB)
Vehicle: 2011 Honda Odyssey Touring Elite (w/Nav)
RB Version tested: latest build as of yesterday
Result: flashing “unsupported” on the stereo.

It plays files from flash drives fine, so I figured it would see it as just another hard drive - nope. Booting to iPod GUI and it works fine.

Please let me know how I can help test.


I had a problem with my iPod dock (a logitech Pure-Fi Elite): when I turned it off, the iPod didn’t stop playing music, and so the dock was immediately turning back on.
So I wrote a little patch that does the work correctly, and I join it.

But the code the dock is sending is not documented, at least when a searched this web page , as I was advised in IRC.
So would you be kind enough to test this patch, and tell me if it doesn’t work as expected ? (The worst this patch can do is stopping music playback inappropriately…)

And I want to thank you all rockbox developers for having made a so nice and commented code, that I could hack very easily…


What do you want us to test? if the patch works? Or if the code looks OK (according to coding style, etc.)

But mainly, I would like that you ensure that the patch doesn’t stop music playback when you are using another function of your iPod accessory… So you can apply the patch, then connect the iPod to your accessory, start music, and try all the functions of your accessory (just press every buttons) …

AndyP commented on 2011-04-23 11:34

Hi, Still working on getting my iPod 5 5 to work with the Alpine.
Have managed to get a bit further but now have an issue with the Alpine sending a code that Rockbox discards.
I have attached the log ( created with the Apple firmware by capturing the serial port in/out commands.
The Alpine sends the following command (line 35), FF550001F704003200000100C000420000003000000………………000009F which according the iPod Extended Interface Specification Release R21 is a SetDisplayImage command which writes a bitmap to the iPod in a ‘large telegram format’. Rockbox rejects this because it uses a value of 00 in byte 2 to denote the large telegram format but this byte is normally the length of packet and Rockbox rejects it because it is 00, so I need to do some work to get it accepted. Any thoughts on the best way to implement this change ?

As the Alpine does not get an ACK for this command, it times out and eventually reports an ERROR-01.

But still making headway, 1 line at a time


Apparently, no one cares about my previous patch..
But I wrote a new patch to support different features related to playlists.
As this is my first consequent patch, it may not be in Rockbox code guidelines. So please review it…

   iap.c (29.5 KiB)

Hum, I posted iap.c instead of the patch

lovasoa, I think your logitech_shutdown patch can be quickly accepted, but we first need your real name for that.
I can’t really comment on your iap_playlists patch, I’m no playlist expert (and I don’t even own any ipod or ipod accessory to test it with).

AndyP, I think you’re right, we don’t seem to have any handling at all for large packets indeed. I think the proper way to handle this, is:
* teach the function that handles packet framing and checksumming (iap_getc) how to handle large packets, its output should be a length word and a buffer pointer
* modify the handle_pkt functions to take the length word and buffer pointer and operate using that, instead of trying to extract the length by itself from the receive buffer.

My real name is Ophir LOJKINE.
For my playlist patch, there is only one playlist-related function that I call. I think you can review it: the main problem may be the coding style…

Attched is a patch that updates the iap_getc function to also handle large packets. The patch introduces a state machine for that, which (IMO) makes the de-framing code much easier to follow.

This patch completely freezes my iPod (black screen) when I use the “get playlist” lingo from my accessory…

Lovasoa, sorry to hear that. I don’t know yet what causes this exactly, I’m suspecting a race condition.
I’ll continue with the large packet patch in a  FS#12135  :

iPod Video, 5.5G, 80GB model. Motorola D670 Bluetooth transmitter, Rockbox SVN r30212.

When plugged directly power the light on for 2 or 3 seconds but does not connect or register with a bluetooth headset. If plugged in the “View PCF Register” Debug Item, the dongle is correctly initialised and seek for a bluetooth headset (first to register then to connect).

The remote control only work for fast rewind and partially for fast forward with my bluetooth headset (Sennheiser PXC310BT)

Hey all,

Back again in Rockbox 3.9, iPod Video 30GB. Same Sony BT accessory, same Sony BT headphones. Haven’t used either in a while, so obviously the >3.4 thing exits. Does the patch from October last year still work, and is the recommended way to get this working again? Or should I load up VMWare Player and find the variable I changed?


Back again. Added normal IAP patch, came up with an iap.c.rej. Went to make, and all seemed to build fine. Attached the .rej file. I could have sworn someone in this thread told me to manually change a serbuf == value, but I can’t seem to find it. Will post back if/when it works/breaks!

   iap.c.rej (45.5 KiB)

Using Rockbox version 3.9.1 (latest stable as of today) on iPod Video 5th gen 80GB, although I’ve already noticed the problem on earlier versions.

Controls on the iPod work fine when docked to JBL On Stage II external speakers. However, the some of the remote control’s buttons don’t work.

What buttons work as expected:
VolumeUp and VolumeUp long press- increases the volume on the speakers (iPod volume untouched)
VolumeDown and VolumeDown long press - decreases the volume on the speakers (iPod volume untouched)
FastForward long press - forwards playback within the currently playing song
Rewind long press - rewinds playback within the currently playing song

What doesn’t:
FastForward - rockbox treats the button as a long press instead of skipping to the next track
Rewind - rockbox treats the button as a long press instead of replaying the song from the beginning
Pause/Play - stops the currently playing song and returns to the main menu instead of staying on the playback screen; slow/no response when resuming playback while at the main menu

There is probably something wrong with the button mappings or perhaps some unimplemented features? I’d be glad to help if you need more data on the problem.

Thank you.

iPod Video 5G, 30GB. Trying RB 3.10 with Sony Stereo Transmitter TMR-BT8IP Bluetooth dongle, and Sony DR-BT101 Bluetooth headphones. No joy still. Tried with Accessory Power on/off, Line Out on/off.

I blew away the dev environment a while back, so I didn’t try the patch up above, from 23 October, 2010. Is there no work being done upon this wonderful aspect of Rockbox anymore? Is this related to 10623 at all? Should I look at both when trying this? At a loss, and the battery life in 3.4 is abysmal compare to the newer versions. Any ideas? Any feedback on my previous posts?

AndyP commented on 2011-12-21 20:37

Hi Josh,

Things have moved a bit with IAP.
From my point of view, I have manged to get my iPod Video 5.5G to function with an Alpine Head Unit using some code from a git tree based on inputs from  FS#12135  (IAP Large Packet Support). I don’t know if this will help on your issue.
Would you be willing to risk a build that I made from this git tree at ? This build includes a patch that will dump a max of 64K’s worth of IAP commands to disk wheh selected via System→Debug Menu→Dump Log File.

It certainly wouldn’t hurt, as I have the iPod Video in front of me, and a clean backup of the 3.4 that was running.

Though, I don’t see a place to click ‘download’ for a pre-compiled binary. I take it that tree needs to be compiled for it to run on anything? Which means I’d have to re-setup the dev environment, huh?

AndyP commented on 2011-12-21 21:25

I’ve just copied it to

Andy, thanks. Though, for my 5G iPod, isn’t it 32MB for the 30GB and 64MB for the 60/80GB?

And just to be sure, this does not allow the dongle to do anything other than blink twice when pressed (after plugging in, nothing happens). The headphones don’t seem to respond at all, either.

Again, tried Accessory Power Supply on/off, Line Out on/off. Rebooted between tries, as well. Nothing. :(

AndyP commented on 2011-12-21 22:01

The latest code should work on both 32MB and 64MB iPods.

When you have tried everything, go into System→Debug Menu and select Dump Log File. You should then have a file in the root dir of the iPod that should contain the last 64KB’s worth of IAP commands. It would be good to get a copy of this file and see if its actually doing anything.

Here is the log of me starting up, looking at the Line Out and Accessory Power settings, plugging in, waiting, pressing dongle button (headphones were already discoverable), LED blinks twice, waiting, removing dongle. Rebooting (hold select + Menu), turning Accessory Power off (nothing happened), then Line Out off, and Accessory Power on, got the blinking twice, but nothing else.

Soap commented on 2011-12-21 22:17

I don’t believe it is your problem, but why are you rebooting with Menu+Select? That’s not a clean shutdown and should only be used to escape from hanging crashes. It’s akin to pressing the reset button on your PC.

Hm….I never thought of it that way, though you are right, now that you mention it. I will run the tests again using the ‘clean’ shutdown method, and then reboot.

AndyP commented on 2011-12-22 12:46

A quick look in the log file suggests that the ipod is not getting the proper information in the IdentifyDeviceLingoes (0×13) command.

Can you ensure you save the log file before rebooting/shutting down the unit. I can’t remember if the log appends or overwrites if you do multiple dumps to disk so it might be worth renaming the file before yo write to disk again.

Just retried the tests using the clean shutdown. Also, before I did, I read your comment here, and looked at the log via ‘view log’, and it seemed to continue incrementing the timestamp. Here is the new log.

Unfortunately, I did not rename the log, I though it would auto-increment the name to the date/time. Hope this helps with this 0×13 command!

Here be another log for your log-viewing pleasure. Deleted and started anew! Still the same filename, though!

AndyP commented on 2011-12-22 20:34

The log name is created at compile time so will always be the same for this build. It is also set to overwrite if it already exists.

I have created another build that appends instead of overwriting.
I have copied this to Nothing else has changed within the build.

There is also another build that automatically creates a log file of the serial commands in a different manner but it sometimes causes the ipod to hang.
If you could run this one as well. I have copied this to

Have looked at the latest logs and it still appears as though the IdentifyDeviceLingoes command does not appear to contain the correct amount of data.
Will see what these later ones show.

Tried your second build with appending log, here you go. About to try the third build with the different serial logging.

Tried your crash-prone build, and could successfully do one run-through of testing before it froze. So that is, plug-in, press button, blink twice, then it usually froze if I tried anything else other than pull the dongle out.

I see it produces TWO logs…..Well, here they are for your debugging pleasure!

AndyP commented on 2012-01-06 21:52

Hi Josh,
Sorry its been so long to get back to you.
Rockbox is returning an error that lingo5 is not supported as it has been disabled in the latest git/svn versions.
I have copied a new version of rockbox as where I have re-enabled support for lingo5.
Can you see if this performs any better. It should not hang up as I removed the extra logging to seriallog.txt…….

Just tried out the new version you posted. For fun, I tried a brand new build (r31646-120109 for reference), and it seems the codecs etc in it don’t work.

Also of note; IT WORKS. Well, it seems to find and pair with the BT headphones, though, since I can’t play anything (not sure if version incompatible or what) I can’t tell if they actually pass data other than heartbeat type stuff.

Should I be using your specifically modified build? Is it possible to repeat the steps for each new version? If it’s reasonable, I can do it myself; I used to add patches (the patch here, in fact) to Rockbox source to make it work.

Thanks for all your help! Will try with your original build. Ah, and here is your log!

Back again. Looks like your original modified build, and your newest rockbox.ipod works! Also, going by build number, this is just before 3.10 was released. Pretty sure there weren’t any major changes between then and 3.10 and now, but I’d still like to update it a bit, at least to 3.10 :)

AndyP commented on 2012-01-13 17:03

Hi Josh, Have just received a TMR-BT8iP from eBay, just waiting for the headphones so I can see whats happening and what its really doing. Will see if the Sony will pair with my notebook.

I will try to patch my copy of the latest svn source with the iap changes from and upload a full build. Might take a few days to get it all done.
Will post when completed.

AndyP commented on 2012-01-25 22:06

Hi Josh,
Finally managed to build a version of Rockbox from git (wondered why svn did not seem to update) with the iap bits from camperquake and lingo5 support for BT transmitters.
I have tried it with the Sony TMR-BT8iP and a set of BT headphones SX-910A. Can hear music and can ff/rewind.
The new version is available from Do you want to give it a try?


Awesome, someone else with my BT adapter! So, is there a write-up somewhere on how to enable the lingo5 stuff? I don’t mind getting my hands dirty in the dev environment. And what is in camperquake?

Thanks a lot for you help! The GF is really really happy she can use her BT headphones again! Well, with an updated, better-battery-life version of Rockbox!

To my limited testing, the build you posted works, though I don’t recall if I tested the FF/RW buttons. I just backed-up your previous (pre-3.10) build, and put this newer one in.

Andy, thanks for your version, which it works for me, but with little bug. I got TMR-BT8iP and headphones sony DR-BT101.On headphones, buttons ff/rewind works great, but when I press play/pause button to play after pause it goes to main menu and it nos start music. also after this if I play by ipod there is no sound in headphones until I press play button again. any sugestions?

AndyP commented on 2012-02-26 19:28

Hi Obloczkus, I’ll have a look with my adapter and headphones and see if it gives the same issue.

Will take a few days before I can check.

Hopefully all the patches I am using from camperquake will be in the standard git release shortly. That way you’ll be able to use the normal daily release and more people might get to use the BT adapter and headphone on Rockbox.

AndyP commented on 2012-03-01 19:46


My adapter and headphones appear to have the same issues. Will look and see if I can determine where the issues are.
Not sure how long it will take

Talon commented on 2012-04-07 01:03

“Challenger dva-9705 Navi” - with ipod input onboard…
when connect my ipods (4g or 5g Ipod Video) on apple fw - them sent to chellenger display main info (current album, songs title, tottal and curent number of plylists, current time etc.) and i can control (pause, play, ff and rewind) with no problem
but on Rockbox fw - its usually bad or no info sending, sometimes it can be first song tittle but not current, often info is empty
usually cotrols not work but sometimes it work… :\ sometimes it work but from second or third click on controls….
RB ver. 0c4bd3a

Any updates on getting this put into RB main, so I (we) don’t have to worry as much when upgrading? Or could AndyP kindly do an update using 3.11? :)

AndyP commented on 2012-04-15 19:57

Hi Josh,
As luck would have it I’d just built a new version for the iPod Video based on the latest git code from yesterday, Apr 14th. It’s available from if you’d like to give it a try. Not sure if the BT bug is still there.
This might also work on the Challenger dva-9705 Navi. Would be good to know.

Andy, problem with BT is still there. well, for me. Honestly, I don’t see any changes with your last version. I’m going back again to v3.4 (last working well one ;)
Thanks for trying.

Awesome,. thanks! Will try this out when I have that iPod and BT dongle! :)

Finally got a hold of the iPod Video. It seems to work in my couple minutes of testing. Backup is ready to go if anything goes wrong, though!

Whoo! Stable, up-to-date Rockbox with BT dongle support! :)

piggz commented on 2012-04-19 17:28

I have a Kia Pro Ceed 2010. It comes with an Ipod cable, that is an ipod → 3.5mm + usb. Using a stock ipod nano 6g, the ipod goes into accessory mode, and can be controlled by the radio. I am able to select album/artist/genre etc, and track names are displayed. With my rockbox ipod video 5.5g, it is less predictable :)

Sometimes it goes into Aux mode, which is ipod controlled, and that obviously works fine, but mostly it does get detected as an ipod.

It will typically continue playing the song that is on
Navigation to next/previous track works ok
Sometimes the radio display shows the track name, other times there is garbage
Using the ‘list’ function on the radio to navigate genre/album/artist/song doesnt really work, nothing is displayed
Sometimes the radio gets stuck saying ‘reading’ and the ipod appears to be locked up

Any hopy of getting this working? Anything i can help with debugging wise?

Rockbox 3.11, AndyP’s build including extra lingo support (?), on iPod Video 5G. Does not work in 2012 Honda Fit Sport, using the USB cable adaptor, with an Apple Dock Connector cable. Comes up ‘Unsupported version’. This is using stock radio, not the fancy NAVI system.

Also tested with stock RB 3.11 on iPod Mini, also comes up ‘Unsupported Version’

Not really a big deal (can use the AUX cable just the same!), just reporting incompatibilities!

AndyP commented on 2012-06-21 19:06

Hi Josh, when trying to use Rockbox with the 2012 Honda Fit Sport, were you connecting using the standard Apple 4 Pin USB cable?
If so, the Honda is probably trying to use IAP over USB which is not supported by Rockbox at the moment and I do not know if anyone is working on this.

Yeah, trying to use the USB adapter in the upper glove box. I didn’t expect it to work, but I thought it would be a neat feature. Ah, well! :)

And why the specific mention of the 4-pin USB cable? Is there a <4-pin USB cable that might work?

AndyP commented on 2012-06-21 19:31

I was specific about the 4-pin USB as some people think that all car audio Apple Dock Connector Cables use USB connections but a lot of them are still using custom cables that are really serial/audio connections.

I don’t know of any cables other than the serial/audio connected ones that will work with Rockbox.

AndyP commented on 2012-06-28 18:51

I was specific about the 4-pin USB as some people think that all car audio Apple Dock Connector Cables use USB connections but a lot of them are still using custom cables that are really serial/audio connections.

I don’t know of any cables other than the serial/audio connected ones that will work with Rockbox.

Talon commented on 2012-07-04 22:58

trying RB: 3d0459d
but any changes with my Challenger dva-9705 Navi :\
controls work sometimes and no info about song send to head display :\

Talon commented on 2012-07-22 02:52

any response?
maybe i can help by some logs or tests?

AndyP commented on 2012-07-24 19:02

Hi Grey,

I assume that you are not connecting through a standard iPod - USB cable.
Are you willing to try a custom build from my server ? There is a version that I built on 20120414, a few lines up in this post. Would you be willing to try this version ?
It would be good to see if this works or not.
There should be the ability to dump a log file of the IAP commands sent by going from the root menu → System → Debug → Dump Log File if it doesn’t work.
This should give an idea why it didn’t.

Talon commented on 2012-07-26 01:49

hi Andy
tnx for response
i did not notice post with your build and waited 4 months :/
i try this build but did not see any changes :\
logs in attach

Talon commented on 2012-07-28 00:02

…. and sure i connecting through not a standard iPod - USB cable.
this cable goes from back of head and its impossible to change him… but as i told early - apple FW work fine…. - show info about track to head, show video and work all button

AndyP commented on 2012-07-29 18:42

Hi Grey,
Have looked at the log file but it does not show where the authentication was done so I can’t see what options are supported.
It does show that the iPod is talking using IAP over Serial and not IAP over USB so we ‘should’ be able to get this sorted.
Can you dump another log to disk that is saved approx 1 - 2 minutes after the iPod has been connected to the Challenger?
Hopefully this will contain the required info.

Talon commented on 2012-07-30 22:47

hi Andy
another one log is attached
when i connect the ipod - i heard the music and make several switch a track to fw and bw
to end of log i switch on head from video mode to playlist mode and lost possibility to change track :\

AndyP commented on 2012-07-31 18:12

Hi Grey,
Thanks for that log. Unfortunately it does not contain the authentication either. Can you dump the log a couple of seconds after you first hear the music being played. This should be just after the authentication has taken place.
I will try to make a build that will automatically dump to the log file to try and see what is happening at the video/playlist mode switching.
The current code does have an issue where it does lock up when you send it too many commands too fast and we are not sure why at the moment.



Talon commented on 2012-08-10 23:32

turn ignition ON
head is startup and i hear the music - save log

AndyP commented on 2012-08-12 17:52

Hi Grey,

I have looked in the attached file but I cannot see any authentication commands in it. Your head unit must authenticate very early in its startup and it being overwritten by later iap commands as the log buffer wraps.
I have created a new build (based on the latest git sources) that will automatically log every iap command into a file and does not overwrite, it just appends. Can you try this version and attach the created log file. The zip file is available from It should create a log file called

Talon commented on 2012-08-21 21:16

Andy hi
i put your version on ipod - but it not playing any songs in any formayt… just leaf files by playlist…. the way it should be?

AndyP commented on 2012-08-22 18:04

Hi, I have just tried the code again after downloading it from the above location and it did play mp3 files. (I only have mp3’s on my ipod.)
Did you install all the files including the codecs ? This build requires all the contents of zip file to be extracted.
I did notice that sometimes my head unit would error out when waiting for the ipod to authenticate, but if I waited until Rockbox had started playing before I connected it to the powered up head unit it would authenticate and play properly. I think this is because the ipod is too busy during the initial powerup and it misses some iap commands.
Due to the writing to disk of all the iap commands, eventually the ipod will ‘panic’ and display an error message on screen. This is expected but by then it should have written enough to disk to capture all the authentication commands. (takes a couple of tracks before this happens, should be enough time to go in/out of video mode a couple of times).
Can you give it another try ?

Talon commented on 2012-08-22 22:59

hi Andy… its my fault… i put your version over i have and have early posted gluck… (its i usualy to do - put any new version just over i have)
when i delete .Rockbox folder and put yours on clean ipod - its start to normal playing songs

i try to connect him to my head - but long time did not give control from head to ipod… and only when i power off head and power off ipod - coonect them and turn ignition on - head start then ipod start and lets play the music - i give some access to control but not as usuasly correct… ipod stay on pause when i long click rewind on head or try to rewind when i short click for changing track… and i try to save dump after thets all )
i hope thets dump shows to you something interesting at last ) (3.7 KiB)
Talon commented on 2012-08-27 10:14

hi Andy…. maybe more logs helps you?
…often, when i press rew or ff - ipod do list over 1 or 2 track or do “stop” or pause… -or another gluck /

Is AndyP’s download link no longer working? I just received a Sony TMR-B8iP adapter from eBay and would like to get it working with my iPod 5.5g.

AndyP commented on 2012-08-28 11:13

I have just tried and it worked OK for me.

However, I have uploaded a newer version for the 5g to the following location,
This was built on 24 Aug 2012 using the latest sources from the git repository with the additions for iap support, including bluetooth.
This copy has NO debug code in it and should run with fewer issues.

A copy that does have debug code in it is available from
This was built from the same sources but will write all iap commands to disk. This can cause ‘panics’ so should only be used when trying to collect iap command for later viewing.

Hi Grey,
I had a quick look through the latest logs you uploaded and cannot see why it should not work. It does not look as though your head unit is using any of the commands that require authentication which explains why it does not authenticate. Would you like to try the non debug code from above on your system. This might work better than the debug version if there are issues with some critical timing between the head unit and the ipod. I’ll look at the issue with the FF and Rew. This could be timing related.

Any feedback on what does and what does not work would be useful. Please note that you have to install all the file from the zip, especially the codecs.


Talon commented on 2012-08-29 15:23

hi Andy
yes - version without DEBUG work more stable… track normal switching to next and previous and working PLAY/PAUSE…
thats all… - i cant rew or ff by long pressing next/prev button and still no showing track info on head unit :/

Talon commented on 2012-10-20 23:45

Hi Andy
no anymore ideas for my Challenger / ?

AndyP commented on 2012-10-23 19:37

Hi Grey,
Have looked through the log files and I can’t see why it doesn’t want to get/send track info. My only thought is that the reported version for lingo4 is not high enough as that’s the only command that is looking for a version.
I have created a new version of rockbox for the 5.5G with a later reported version for lingo4 and it can be found at along with a debug version at, do you want to give them a try and report back?
I have tried looking for a Challenger DVA9705 Navi in UK but it does not seem to be available here and I couldn’t find one while I was in Hungary a couple of weeks ago.
If it still doesn’t work the only real option is to capture the commands that the Apple firmware and Challenger send. To do this you would need a ipod breakout board and serial port to capture the commands. We could look at this if this version is no better.

Talon commented on 2012-10-23 21:32

Hi Andy
tnx for still responding )
sure i try thats version and send report! but only on next week… im hope…

Talon commented on 2012-11-01 23:01

Andy hi
thats log from yours last build

AndyP commented on 2012-11-07 21:11

Hi Grey, There doesn’t seem to be anything different in this log so I’m rather confused as to what the Apple firmware responds with, or sends to, the Challenger. I think the only way forward is to capture the commands sent when the Apple firmware is running.
Would you have the ability to connect a couple of serial cables to the iPod Tx and Rx lines on the 30 way connector so we can see what commands are sent? I used a couple of 3 wire Nokia USB cables (CA-42, or DKU-5) and a breakout board with connectors from Ridax ( but i’m not sure if it’s still available. Other boards might be available.
Without this I’m not sure if there is much else we can try.

Talon commented on 2012-11-07 23:20

hi Andy… suxx (
thats to difficult for me…. im not electrician /

AndyP commented on 2012-11-08 18:59

Hi Grey, Will have another think and see if I can come up with something else to try.
What version of Apple firmware do you have on your iPod?

Talon commented on 2012-11-09 02:21

hi Andy
glad to hear it )
ver.: 1.3
s/n: 9C7287GRV9M
model: MA446ZP
format: windows

I would like to report that Rockbox does NOT work with the official genuine Mazda iPod Integration Kit

Two different kits were used… both kits apply to the following models of Mazda cars (official list from Mazda USA):
2004-2008 Mazda3 (including Mazdaspeed3)
2006-2007 Mazda5
2005-2008 Mazda6 (including Mazdaspeed6)
2004-2008 Miata
2004-2008 RX-8
2007-2008 CX-7
2004-2006 Tribute
2007-2008 CX-9
2004-2006 MPV

Also the following cars now depreciated from Mazda’s official list (was in their early list but removed due to LCD display too small in those vehicle’s head units, making difficult to use):
2001-2003.5 Protege
2001-2002 Millenia
2002-2003 MPV
2001-2003 Tribute
2002-2003 Miata

The vehicle being used in is not of importance as radios are internally similar between cars of certain year ranges. Mazda internally designates 2001-2002 cars to use the “Phase 1” modular audio system, including the 2001-2006 Tribute and 2001-2005 Miata. 2004-2006 Mazda3s and RX-8s used the “Phase 2” modular audio system. Everything else used up to 2008 used the “Phase 3” system. “Phase 4” systems are not compatible with the two different interface kits I tested and are used for 2008.5 and newer Mazdas of which a different official interface kit from Mazda is available.

Kits tested are (Mazda part number shown):
C236-79-CFZ in a 2001 Protege (phase 1 system)
C9F2-V6-572-US in a 2005 Mazda3 (phase 2 system)
These official integration kits are manufactured by Sanyo in Malaysia.

iPod used: old style/classic 4th gen color
Rockbox version: 3.1.2

RESULTS (what matters, in the list please do not list the vehicle model tested in the wiki list, only the vehicle make and the kit part # because these kits apply to multiple vehicles and behave all the same as explained):
C236-79-CFZ kit: ZERO functionality, head unit displays “NO DISC” (integration kit uses external CD changer port as an official hack), only charging and power on ability works
C9F2-V6-572-US kit: No remote control functionality (ipod cannot be controlled from head unit). Charging and power on ability works. Audio playback works only up to 25-30 seconds by manually selecting the track from the ipod directly, then the integration module shuts down due to “inactivity time out” (or something like that)

AndyP commented on 2013-01-29 20:59

Hello TheMAN,

I have just built a version of Rockbox for the ipod4G that has the same updates to the IAP commands as the ipod5G firmware further up this page that allow the 5G to work on my Alpine head unit. Would you like to give this a shot on the C9F2-V6-572-US kit as this might fix it? I don’t think it would work on the other but you never know.
The firmware is available from

was it the 5th gen or 6th gen that Apple changed the pin assignments of the 30 pin connector so that charging no longer worked with existing (old) car integration kits?
I’ll give it a try when I have time but I don’t have high hopes

Can you please update the wiki when you have time?


Error: couldn’t load rockbox.ipod, bad checksum

AndyP commented on 2013-02-01 20:34

My 5.5G iPod works with old style integration kits so they must have changed the pin assignments on the 6th gen.
I have just uploaded a version for the 4th Gen colour, rather than the 4th gen grey scale. Its at http:// It might work better on your classic 4th gen color. Do you want to give that a try?

AndyP commented on 2013-02-01 20:43

A slight error with the location. Try this one

Ok, the build works this time, but the behavior is still the same on both cars… same results as first time I tried using the stable release build:
C236-79-CFZ kit: ZERO functionality, head unit displays “NO DISC” (integration kit uses external CD changer port as an official hack), only charging and power on ability works
C9F2-V6-572-US kit: No remote control functionality (ipod cannot be controlled from head unit). Charging and power on ability works. Audio playback works only up to 25-30 seconds by manually selecting the track from the ipod directly, then the integration module shuts down due to “inactivity time out” (or something like that)

rockbox settings were changed to “car adapter mode” ON and no difference

Thanks for trying anyway, I don’t think this will ever work unless the docking protocol gets hacked… I’ll have to live with the stock firmware some more I guess :(

So I guess it’s really ok for you to update the wiki page this time? ;)

AndyP commented on 2013-02-02 11:48

A slight error with the location. Try this one

I did!
Rockbox boots up and works, but mazda car integration behavior is the same! I’m telling you the mods you did to the build doesn’t work! Nice try, thanks for the help!

AndyP commented on 2013-02-02 18:56

Apologies, I didn’t know that when I did a refresh on this page it would resend my last comment.
Would you be willing to try a debug build that could log all the IAP commands to and from the head unit. This could help in determining where the issue is with the C9F2 unit?

I would if it’s all automagic and I won’t have to jump through hoops to do the debugging… I don’t have the time to get my hands all dirty digging through code or issuing special commands to do all this ;)

AndyP commented on 2013-02-13 20:27

I have updated the wiki with the Alpine CDE-103BT.

I have built a new version for the ipod color that should automatically write all the transmitted and received IAP commands to a file in the ./rockbox directory before it finally crashes. You might need to run it a couple of times up to the point where the head unit complains about ‘inactivity timeout’ so as to ensure that all the commands are captured. Hopefully with this log I should be able to see where the issue is. This build is available here Do you want to give this a try?

which file does it write to?
this build is buggy (no surprise)…. it locks up the ipod at times and I had to do a hard reset… ogg playback is also broken, but I did manage to play an MP3 with it in the car long enough to hopefully capture the commands… I also used the controls on the radio to see about sending the IAP commands to the ipod, hopefully those got recorded!

AndyP commented on 2013-02-14 18:14

It should write to a file in the ./rockbox directory called logf.txt.201202111905.
Did it timeout as usual, or did it play for longer?
I’ve never tried ogg playback for a long time and the IAP commands should not affect it. Something to look at later me thinks.

no log file written
same timeout as was before, for the most part…. I got it to last a little longer by fiddling with the radio’s controls, but once the selections timed out, it killed the line in

AndyP commented on 2013-02-14 18:27

Hmmm, it should have wrote a log with something in it.
The same source built for my 5.5G Video manages to write one most of the time before finally hanging up.
How many times did you try it?
I’ll try to build a new one that might be a bit more stable. Might take a couple of days though.

tried it two times only, didn’t see any log files… not even a single byte
ogg playback worked in your previous build from the 2nd

AndyP commented on 2013-02-14 21:27

OK, will try to see what’s changed with ogg since 2nd.

AndyP commented on 2013-02-22 23:55

Hi, haven’t forgotten about this issue. Have just bought ipod photo on ebay to try and help me with the issue.
Have noticed that there appears to be no tx/rx activity from any version of rockbox, release, git or my patched version.
Not sure if the ipod photo is supported as the patch from rpress in 2009 appears to show that the color ipod used ser1 for the dock but all the code in serial.c is for ser0.
As I now have a color I will try to include the patch from rpress to my current code and see what happens on the color and the 5G.
Will probably take a while.
Does anyone have a color/photo/4G ipod that can currently be controlled via an accessory using the latest release of Rockbox?

AndyP commented on 2013-02-25 18:49

Hi, There were some issues with the code for the iPod photo around the serial driver.
I have uploaded a new version for the iPod color/photo to This version works on my color iPod with an Alpine Head Unit.
This version does not have any debug code in it and should work OK.
There is also a copy with some debug code in it at that will allow you to dump the last few IAP commands to a log file called
/logf.log.20130225xxxx by going to the Main Menu and selecting System → Debug → Dump log file. Hopefully this will dump enough commands if needed.
Do you want to give these a try?

I tried to control my iPod Classic (6G with 160GB and the Rockbox r31516-120101) with the remote control of my Harman Kardon Go + Play II. But it doesn’t work with rockbox.
Can you plaese help mi?

AndyP commented on 2013-03-24 20:32

Hi Sven,

Someone please correct me if I am wrong, but I do not think that the iPod Classic has support for IAP in Rockbox at the moment as there is no support for the serial port on that device.
Until the serial port is supported, IAP cannot be supported and I can’t find support for the serial port in the source.

Andy, your test build shows a LOT of promise. For once, playback DOES work on both the Mazda ipod interfaces. I have dumped the log files tested from both cars.

First lets start with the Mazda3 with the C9F2-V6-572-US ipod interface connected to the phase 2 factory head unit
Playback is finicky. Most of the time, I had to start playback first before turning on the headunit, otherwise audio would skip every half a second or so.
NONE of the playback controls (remote) works properly. If I hit FF or RW, it would result in audio skipping, depending on the severity of the button presses. Hold down FF and the audio skips indefinitely until I tap RW once. The “change disc” button is supposed to switch albums/playlists/genre/artist. Pressing it results in the headunit indefinitely trying to look for something. Another issue is the playback time would either be permanently stuck at 2:00:00, or at 0:00:00. Resume playback does not work (not surprised), or does remote shutdown works. When you turn on the headunit, it knows the ipod is there and you can hear the line in source enable. You must manually navigate on the ipod to start playing a song.

Despite the buggyness, playback can now be continuous as the interface is seeing IAP commands, it no longer stops line input and the interface no longer just shuts off.

Attached is a log file of the Mazda3 test… I button mashed as much as I could to get the system to log the garbage.

Next test, just for grins was on the Protege with the C236-79-CFZ ipod interface kit connected to the factory phase 1 headunit.
Results were MUCH MUCH better than with the Mazda3. To my surprise playback works. No more “no disc” error on the headunit’s display. The interface box is seeing the ipod connected to it. The IAP commands must be doing something! ;)
I can just turn on the headunit without starting playback first. Playback is flawless. No skipping. The FF and RW buttons jump between tracks, not as designed. They were meant as fast forward and rewind functions for a track. The change track buttons does not work, just like it was on the Mazda3 (which I failed to mention). What’s different when using the change track button on this interface/headunit though is just a momentary audio skip. “change disc” buttons do not work, which wasn’t surprising. However, the headunit or interface box was smart enough to give up after 10-20 seconds and resume playback. Resume playback from a shut down or idle state does not work. Remote shutdown doesn’t work either. Just like on the Mazda3, you can hear the line in source enable when you turn the headunit on. Almost all controls must be done manually to start playing a song. The unintended FF and RW buttons work though!

This is my final test. I don’t have time to beta test and I don’t want to deal with unreliability especially since I lost everything from an ipod hdd crash recently. I don’t want to take the chance of rockbox screwing something up on my CF card converted ipod. I hope you understand.
It looks like progress has been made and can be furthered. I think with continued efforts, you can make this compatible with the genuine Mazda Sanyo made ipod interface units.

Thank you and I do think Rockbox is awesome. I will have to come back to it in the future once rock solid compatibility has been made for the Mazda interfaces.
I wish you all luck!

Hello team,
faced a problem with kia car ipod iphone ipad cable (
Connecting ipod video 30 GB, rockbox V3.13 to a car via this cable - face the following issues:
1 (-). Album replay mode turns on on its own and can’t be turned off (when standard ipod connected it gets kia logo on it’s screen, so I guess it turns on album replay mode).
2 (+). Ipod keeps it’s functionality - all the user interface etc
3 (-). Playing songs can’t be heard in speakers as it is mute (once, after strange sequence of actions trying to make something work music became heardable but only once)
4 (-). Steering wheel track changing buttons doesn’t work well - sometimes ‘back’ works if pushed twice, forward doesn’t work generally at all. Mute button doesn’t change anything except line ‘muted’. (when usb flash drive connected mute button works as pause)
5 (+). Name of the song is correctly displayed on the car multimedia display.
6 (+). Ipod charges

So far ipod with rockbox is unusable using this cable (unfortunately). Hope this can be corrected.
Thank you very much in advance


Since the wiki does not appear to be working at the moment I would like to report my findings regarding the JVC KS-PD100 ipod adapter that I used to connect an ipod video to a JVC KD-SX992R car radio.

- Skip forward / back works, so does the play button and of course audio playback, i.e. the adapter is usable with rockbox
- Seeking does not work right. It seems that the ipod gets far too many “clicks” from the seek button and will keep seeking long after the button has been released.
- The name of the current song is not displayed. I’m reasonably sure that the track’s time was displayed at first but then I clicked something and now it’s gone. Pretty sure that’s my fault though :)
- From what I can tell you cannot navigate the menu (seeing how there are no buttons for that on the car radio)

I have only tried with accessory power enabled. Since it’s a car radio I didn’t spend a wohle lot of time debugging things so please let me know if you would like me to gather additional information.

I’ve discovered a device that doesn’t work at all with Rockbox. I’ll be updating the wiki in a bit, but I wanted to post my findings here first.

iPod: 5.5 Gen 80GB (Latest Stable release of Rockbox)
Device: Alpine CDE-152 (Car audio head unit)

No matter what settings I play around with in Rockbox (Car Audio - On, Accessory Power - Off, etc.) the head unit refuses to communicate with the iPod. All I get is an “Error 02” on the main display of the head unit. According to the owner’s manual, Error 02 apparently means “Caused by the iPod/iPhone Software Version not being compatible with this unit.” It works perfectly fine with the stock iPod firmware, but that kind of defeats the purpose.

It’s probably a snowball’s chance in hell of getting Rockbox to work with this head unit, but hopefully my findings will prove to be useful somewhere. Or at least be a warning to others looking to buy this head unit.

AndyP commented on 2015-11-13 19:36

Hi that1nerd,

A quick look through the manual for the CDE-152 shows that the connection to the iPod from the head unit is via a standard USB iPod lead. This means its using IAP over USB which is not supported by Rockbox. The only option I can see for music playback at the moment is to change the vid/pid to a non iPod pair and have the device treated as Mass Storage.

I’ve discovered a device that doesn’t work at all with Rockbox. I’ll be updating the wiki in a bit, but I wanted to post my findings here first.

iPod: 5.5 Gen 80GB (Latest Stable release of Rockbox)
Device: Alpine CDE-152 (Car audio head unit)

No matter what settings I play around with in Rockbox (Car Audio - On, Accessory Power - Off, etc.) the head unit refuses to communicate with the iPod. All I get is an “Error 02” on the main display of the head unit. According to the owner’s manual, Error 02 apparently means “Caused by the iPod/iPhone Software Version not being compatible with this unit.” It works perfectly fine with the stock iPod firmware, but that kind of defeats the purpose.

It’s probably a snowball’s chance in hell of getting Rockbox to work with this head unit, but hopefully my findings will prove to be useful somewhere. Or at least be a warning to others looking to buy this head unit.

ivi commented on 2016-04-12 19:37

iPod: Mini Gen 1
Device: AUDI MIB 1 High w/ AMI (Audi Multimedia Interface), which is the high-end infotainment device in a 2015 A3.
Rockbox: git from a few days ago with some minor local changes to the WPS screen (git describe says bootloader_zenxfi3_v1-350-g043d65a, last commit pulled from master is 98c15fe85d2e3466d2d345e0f4c8b2a51731be2e)

The iPod is recognized as an iPod, but the AUDI headunit says “no media on device” (or something to that extent).

The logf output (see attachment) shows a few unknown mode 0 requests from the headunit. I’ve searched for documentation about these unknown mode 0 requests, but I couldn’t find anything. Is tools/iap/ suppposed to convert the logf output to something human-readable, or just for reading from serial? I might have some time on the weekend to check whether I can hack something together that makes the logf output human-readable…

ivi commented on 2016-04-12 19:39

forgot to attach the log

   logf.txt (3.2 KiB)
ivi commented on 2016-04-16 14:45

manually analyzing the logf output, I saw that
a) the headunit sends an empty supported lingoes list in the IdentifyDeviceLingoes (0×13) request, which as far as I can see sets the device lingoes list to empty. Afterwards it sends RequestLingoProtocolVersion. I added code to add every queried and supported lingo 1) to device.lingoes, so that the later DEVICE_LINGO_SUPPORTED check does’t fail.
b) the lingo4 code does not return any info about a current track if rockbox has just started without any track playing, I tried to connect the iPod with a track playing, and voila, the headunit plays something and after a short while also shows the track database. I’ll have to check whether this data can be provided also when rockbox isn’t playing anything.

I did a few more local changes and need to now check which change is required and which isn’t before I’ll provide a patch, but I’m very happy to have my ipod now working in my car.

ivi commented on 2016-05-17 15:59

real life interfered. the attached patch does the following:
* add every queried and supported lingo 1) to device.lingoes, so that the later DEVICE_LINGO_SUPPORTED check does’t fail if IdentifyDeviceLingoes(0×13) is not sent with the list of supported lingoes (or is it lingos?)
* implement 0×10/0×11 request/response pair ([Request|Return]TransportMaxPayloadSize). unsure if this is really needed, but it sure doesn’t hurt
* acknowledge a failed mode0 command with cmd_ack(cmd, IAP_ACK_BAD_PARAM) even when logging. headunit behavior can be slightly differently if we don’t send an error on unknown requests

there is also a problem with automatic track updates not always being visible in the headunit, but I still have to debug that one when I find some time

ivi commented on 2016-07-30 10:30

automatic track updates were missing because the headunit uses a 4byte version of the Lingo 4 0×0026 (SetPlayStatusChangeNotification) command, but the current rockbox code only checks for the 2byte version.

attached patch implements some very limited support for this by setting the notification flag if any bit in the 4 byte bitmask is set (not caring for which notifications the headunit really requests)

malak commented on 2018-02-26 11:57

Ipod 5.5 & Grom BT3

1. charging - yes
2. sound - yes
3. car controls - not working

CH23 commented on 2018-05-21 19:01

the Apple iPod FM Radio Tuner Remote Control no longer works with iPod 5.5th gen
I tested it on rockbox versions:
3.13 - works, also detected in debug → FM Radio
3.14 - does not work, not detected in debug → FM Radio
992a126M-180521 - does not work, not detected in debug → FM Radio

CH23 commented on 2018-05-21 20:19

I found the breaking point:

the latest working version:;a=commit;h=500b137308a6ee5c2aba873734a8956d70472f56

the commit that broke it:;a=commit;h=b170c73f922e3457b923b4e7fcbec794a8885c77

what has happened is that the apps/iap.c code, was replaced with apps/iap/FILENAME.c

CH23 commented on 2018-05-21 21:42

I found the breaking point:

the latest working version:;a=commit;h=500b137308a6ee5c2aba873734a8956d70472f56

the commit that broke it:;a=commit;h=b170c73f922e3457b923b4e7fcbec794a8885c77

what has happened is that the apps/iap.c code, was replaced with apps/iap/FILENAME.c

AndyP commented on 2018-08-03 16:58

The attached patch should allow the Apple Radio Remote to function again. I have tested it on my 5.5G.

CH23 commented on 2018-08-04 12:52

Thank you, Andy.

I have tested this as well on my 5.5G, it works!

CH23 commented on 2022-01-31 17:49

Pure i20 dock, which supports Coax and optical out, as well as analoge output will not work with rockbox. in rockbox I see the usb connection screen come up and then go away, repeatedly.(both 'charging' and 'usb present' cycle through 'true' and 'false'

iPod Classic (late 2009 160gb thin), build 466156f0b5M-200929

Since the iPod classic doesn't have anything in I/O but the 15 GPIO lines and USEC, i'm not sure how helpful this info is, but gpio 3, 4 and 5 cycle as follows:

default state of gpio3, 4, 5 = 0x1e, 0xfe, 0xff
changed state 1 of gpio3, 4, 5 = 0x0e, 0x00, 0x80
changed state 2 of gpio 3, 4, 5 = 0x0e, 0x02, 0xc0

Bowers & Wilkins Zeppelin Mini does not work with the iPod Classic gen 6.

The device enters into USB mode and charges. But the sound output is not working.

The iPod Video also doesn't work. But this is to be expected. Because the Mini doesn't support it.

Focal XS® 2.1 Multimedia Sound System:

Audio works. The volume buttons work.

However, the media control (play, skip, next) doesn't work.

Please ignore my previous comment. I made a mistake.

Focal XS® 2.1 Multimedia Sound System:

Audio works. But the volume slider on the iPod doesn't sync up with the physical button on the Focal XS.


Available keyboard shortcuts


Task Details

Task Editing